Website maintenance
Incident Report for Buttercups Training
Resolved
This incident has been resolved.
Posted May 17, 2023 - 12:01 BST
Identified
We will be undergoing scheduled maintenance during 7:30 to 10:30 on Wednesday 17th May and the website will be unavailable. This does not affect the b-Hive which will remain accessible from the following link https://online.buttercupstraining.co.uk/user
Posted May 15, 2023 - 16:37 BST
This incident affected: Website.