Intermittent Phone Issues
Incident Report for Buttercups Training
Resolved
This incident has been resolved.
Posted Jul 27, 2022 - 17:54 BST
Update
We are continuing to investigate this issue.
Posted Jul 27, 2022 - 17:53 BST
Investigating
We are currently experiencing intermittent phone issues at our head office. If you urgently need to get in touch with us please send an email to, training@buttercups.co.uk. If you have a query which is not urgent please fill out the details on the Help form on your b-Hive Dashboard.

We apologise for any inconvenience that this may cause.
Posted Jul 27, 2022 - 11:09 BST